Why am I getting an error message when I click on the login email?
When you log in to the Secure Exchanges online portal, a login email is sent to you to confirm your identity. Clicking the link will normally redirect you to your account in your browser.
If you get an error message at this step, the most frequent cause is the use of two different browsers.
Cause of the problem
You used one browser to request the connection, but another browser is trying to open the link received by email.
Example :
You log in to Secure Exchanges from Google Chrome , but your email opens in Microsoft Edge . In this case, validation fails.
How to fix the problem
Make sure you use the same browser for:
the connection request on Secure Exchanges
the opening of the validation link in your email
Example :
If you use Google Chrome to access Secure Exchanges, the authentication link should also open in Google Chrome. You can change your computer's default browser or copy the link from the login email and paste it into the same browser you used to log in to resolve the issue.
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I am not receiving the login email for the online portal, what should I do?
The login email for the online portal is only sent if the anti-robot code is entered correctly. If an error is made in the anti-robot code, no error message will appear, but the email will not be sent. Simply try again and make sure the code is ...
Is it possible to secure attachments only from the online portal?
No, this option is not available on the online portal. If you send an email from the online portal, the entire email will be secure.
Can I secure online access to my Secure Exchanges account?
Yes, you can secure access to your account from the online portal by choosing to enable two-factor authentication. The following video will show you how to do this:
What are Secure Exchanges?
Introduction Secure Exchanges is a Canadian company founded in Quebec, specializing in the protection of digital communications and the security of sensitive data. Our technology allows organizations to securely transmit, sign, and receive ...
Is it possible to delete my email history via Secure Exchanges?
No, there is no way to delete your Secure Exchanges log history.