Why am I getting an error message when I click on the login email?

Why am I getting an error message when I click on the login email?

When you log in to the Secure Exchanges online portal, a login email is sent to you to confirm your identity. Clicking the link will normally redirect you to your account in your browser.

If you get an error message at this step, the most frequent cause is the use of two different browsers.


Cause of the problem

You used one browser to request the connection, but another browser is trying to open the link received by email.

Example :
You log in to Secure Exchanges from Google Chrome , but your email opens in Microsoft Edge . In this case, validation fails.

How to fix the problem

Make sure you use the same browser for:

  1. the connection request on Secure Exchanges

  2. the opening of the validation link in your email

Example :
If you use Google Chrome to access Secure Exchanges, the authentication link should also open in Google Chrome. You can change your computer's default browser or copy the link from the login email and paste it into the same browser you used to log in to resolve the issue.